Cisco DNA Center - Route-Leak: Fusion Router (NXoS) xBorder(IoS-XE)

 

Cisco DNAC na Vida Real!
How-to Series Guide


 Utilizando Roteadores Nexus da Cisco  como Fusion Router em rede SDAccess
 
Route-Leak: Fusion Router (NXoS) xBorder(IoS-XE) 
 
 

Autor:Josinfo

ago/2020

 

 

Demonstração de como fazer o route-leak entre um FUSION Router NEXUS e um BORDER Router, que pode ser encontrado em uma rede SDACCESS:



Topologia fictícia das Indústrias Wayne:

 




O Fusion Router possui um peer OSPF com a rede SHARED-SERVICE e recebe todas redes da Shared-Services além da Rota Default, a configuração do OSPF não será abordada, então vamos para configuração do BGP:




Precisamos criar um Peer BGP dentro da GRT (Global Routing Table):

 

NEXUS

NXOS-FUSION#

 

feature interface-vlan

feature bgp

feature ospf

!

vlan 1818

 name PEER_BGP_INFRA_GRT

!

interface Ethernet2/2

 description UPLINK_TO_BORDER_e0/0

 switchport

 switchport mode trunk

 no shutdown

!

interface Vlan1818

 description PEER_BGP_INFRA_GRT

 ip address 192.168.18.1/30

 no shutdown

!

router bgp 65001

address-family ipv4 unicast

 network 192.168.18.0/30

!

neighbor 192.168.18.2

remote-as 65018

update-source Vlan1818

 address-family ipv4 unicast

 default-originate

!

NXOS-FUSION#

 

IoS-XE

 

!

BORDER#

interface Ethernet0/0

 description UPLINK_TO_FUSION_e2/2

 switchport trunk encapsulation dot1q

 switchport mode trunk

 no shutdown

!

interface Vlan1818

 description PEER_BGP_INFRA_GRT

 ip address 192.168.18.2 255.255.255.252

 no shutdown

!

router bgp 65018

 no bgp default ipv4-unicast

 network 192.168.18.0 mask 255.255.255.252

 neighbor 192.168.18.1 remote-as 65001

 neighbor 192.168.18.1 update-source vlan1818

 !

 address-family ipv4

  neighbor 192.168.18.1 activate

 exit-address-family

BORDER#

 


Resultado:






Configurando VRF LITE CAMPUS

 

!

NEXUS

!

NXOS-FUSION#

!

install feature-set mpls

  allow feature-set mpls

feature-set mpls

feature mpls l3vpn

feature mpls ldp

!

vrf context CAMPUS

  rd 1:4099

  address-family ipv4 unicast

    route-target import 1:4099

    route-target export 1:4099

!

vlan 2020

 name PEER_INFRA_VRF_CAMPUS

!

interface Vlan2020

 description PEER_INFRA_VRF_CAMPUS

 vrf member CAMPUS

 ip address 10.100.20.1/24

 no shutdown

!

router bgp 65001

vrf CAMPUS

address-family ipv4 unicast

network 10.100.20.0/24

 neighbor 10.100.20.2 remote-as 65018

 update-source vlan 2020

 address-family ipv4 unicast

   default-originate

!

NXOS-FUSION#

!

 

!

IoS-XE

!

BORDER#

!

vrf definition CAMPUS

 rd 1:4099

 !

 address-family ipv4

  route-target export 1:4099

  route-target import 1:4099

 exit-address-family

!

interface Vlan2020

 description PEER_INFRA_VRF_CAMPUS

 vrf forwarding CAMPUS

 ip address 10.100.20.2 255.255.255.0

 no shutdown

 

router bgp 65018

 address-family ipv4 vrf CAMPUS

  neighbor 10.100.20.1 remote-as 65001

  neighbor 10.100.20.1 update-source vlan2020

  neighbor 10.100.20.1 activate

!

BORDER#

 

!

Resultado:






Configurando ROUTE_LEAK NEXUS

 

Ë Premissa que todas redes da SHARED-SERVICES sejam anunciadas dentro de todas VN (VRF), para que isso ocorra será nescessário que o Fusion router faça o Leak (vazamento de rota) entre a tabela GRT (Global) e VRF e Vice versa:

 



O Truque principal está no NEXUS (Fusion Router), onde teremos que fazer o vazamento de rota em duas etapas:

 

Fusion Router:

 

Etapa 01 >>> Vazamento de rota da GRT para VRF:

 

>> Nota: As Rotas que deverão sair da GRT para a VRF devem estár na tabela RIB do BGP (ou seja devem ser anunciadas via "network")

 

Etapa 02 >>> Vazamento de Rota da VRF para GRT:

>> 

 

ANTES:

> Verificação RIB/BGP dentro da GRT

 



DEPOIS:

 

<><GLOBAL-TO-VRF><>

 

NXOS-FUSION#

router bgp 65001

  address-family ipv4 unicast

    network 172.30.10.0/24

    network 172.30.20.0/24

    network 172.30.30.0/24

!

ip prefix-list SHARED-SERVICES seq 5 permit 172.30.10.0/24

ip prefix-list SHARED-SERVICES seq 10 permit 172.30.20.0/24

ip prefix-list SHARED-SERVICES seq 15 permit 172.30.30.0/24

!

route-map GLOBAL-TO-VRF permit 10

  match ip address prefix-list SHARED-SERVICES

!

vrf context CAMPUS

  address-family ipv4 unicast

    import vrf default map GLOBAL-TO-VRF

!

NXOS-FUSION#





Ao final da primeira etapa os endereços da Shared Services, entraram nas tabelas RIB/BG da VRF CAMPUS e RIB/BGP da GRT (Global)

 

Seguindo para etapa 02 precisamos que a tabela GRT Global do Fusion reconheça as rotas das interfaces VRF, ou seja precisamos fazer o reverso VRF para GLOBAL

 

<><VRF-TO-GLOBAL><>

 

ANTES: Ao tentar verificar a rota da VRF na GRT não existe e apenas mostra a entrada da saída default




Step01 >>> Redistribuir as rotas vindas via OSPF para RIB/BGP Global

!

route-map VRF-TO-GLOBAL permit 10

!

router bgp 65001

  address-family ipv4 unicast

    redistribute ospf 1 route-map VRF-TO-GLOBAL

!

Step02 >>>> Anunciar as redes que estão nas VRF (Exportando das VRF para tabela GRT do BGP)

!

ip prefix VRF-TO-GRT seq 5 permit 10.100.20.0/30

!

route-map VRF-TO-GRT permit 10

match ip address prefix-list VRF-TO-GRT

!

vrf context CAMPUS

address-family ipv4 unicast

export vrf default map VRF-TO-GLOBAL

!

route-map VRF-TO-GLOBAL permit 10

!

router bgp 65001

  address-family ipv4 unicast

    redistribute ospf 1 route-map VRF-TO-GLOBAL

!

 

Resultado:

 



show bgp vpnv4 unicast vrf CAMPUS neighbors 10.100.20.1 advertised-routes




Agora é só Sucesso, 

 

"Para o Alto e Avante" 

 
Josinfo - CCIEPOWER 
Regards,




 

 

Comentários

Postagens mais visitadas deste blog

Cisco DNA Center - Demostração Online do Cisco DNA 2.1.1.S1

Cisco DNA Center: 01 - Na Vida Real - Visão Geral

Cisco DNA Center: 03 - Guia de instalação do Hardware - UCS Server