Cisco LAB - OSPFv3

LAB OSPFv3 - VIRTUAL-LINK
Galera o esquema agora é IPv6, só pra descontrair olha um troubleshooting que tive que fazer em uma empresa o seguinte cenario, que era totalmente configurado com IPV6 e OSPFv3.
  • 4 Roteadores [R1]-area0- [R2]-area 11-[R3]-area54-[R4];
  • Todas as interfaces já estavam configuradas com os devidos IPv6;
  • O roteamento ospfv3 também já estava habilitado entre todos os roteadores;
  • Cada roteador tinha um valor configurado para o router-id dentro do ospfv3;
O PROBLEMA:
  • O R4 não estava recebendo nenhuma rota através do protocolo de OSPFv3 (#show ipv6 route ospf);
  • Já tinha um virtual link configurado entre o R4 apontando para o Router-ID do R3;
  • E o mesmo se encontrava em estado Down (#show ipv6 ospf virtual link);
TROUBLESHOOTING
  • Retirar o virtual link que estava criado no R4 e R3;
R4(config)#ipv6 router ospf 1
R4(config)#no area 54 virtual-link 3.3.3.3
R3(config)#ipv6 router ospf 1
R3(config)#no area 54 virtual-link 4.4.4.4


  • Criar os Links Virtuais nos locais Certos entre os R2 e R3;
R2(config)#ipv6 router ospf 1
R2(config)# area 11 virtual-link 3.3.3.3

R3(config)#ipv6 router ospf 1
R3(config)#area virtual-link 2.2.2.2


Conclusão:
Como o R2 é o ASB entre a area 0 X 11, e R3 é o ASB entre a area 11 X 54, R2 tem que apontar o Virtual link para o router-ID do R3 e o R3 apontar o virtual link para o Router-ID do R2, abaixo eu fiz um cenario com o GNS3 e postei os scripts, caso alguém, queira testar.
CENARIO:
========================

Conf R1
service password-encryption
!
hostname R1
!
enable secret class
!
no ip domain lookup
ip domain name jcs.wan.com
!
ipv6 unicast-routing
!
username josinfo privilege 15 secret class
!
ip ssh time-out 60
ip ssh version 2
!
interface Loopback0
no ip address
ipv6 enable
ipv6 address fec0:1::1/64
ipv6 ospf 1 area 0
!
interface Serial1/1
no ip address
ipv6 address 2001:DB8:0::1/64
ipv6 enable
ipv6 ospf 1 area 0
no shutdown
!
ipv6 router ospf 1
router-id 1.1.1.1
!
line vty 0 4
transport input ssh
password cisco
login


=========================
Conf R2

service password-encryption
!
hostname R2
!
enable secret class
!
no ip domain lookup
ip domain name jcs.wan.com
!
ipv6 unicast-routing
!
username josinfo privilege 15 secret class
!
ip ssh time-out 60
ip ssh version 2
!
interface Loopback0
no ip address
ipv6 enable
ipv6 address fec0:2::1/64
ipv6 ospf 1 area 11
!
interface Serial1/0
no ip address
ipv6 address 2001:DB8:0::2/64
ipv6 enable
ipv6 ospf 1 area 0
no shutdown
!
interface Serial1/1
no ip address
ipv6 address 2001:DB8:1::1/64
ipv6 enable
ipv6 ospf 1 area 11
no shutdown
!
ipv6 router ospf 1
router-id 2.2.2.2
area 11 virtual-link 3.3.3.3
!
line vty 0 4
transport input ssh
password cisco
login



==========================
Conf R3
service password-encryption
!
hostname R3
!
enable secret class
!
no ip domain lookup
ip domain name jcs.wan.com
!
ipv6 unicast-routing
!
username josinfo privilege 15 secret class
!
ip ssh time-out 60
ip ssh version 2
!
interface Loopback0
no ip address
ipv6 enable
ipv6 address fec0:3::1/64
ipv6 ospf 1 area 11
!
interface Serial1/0
no ip address
ipv6 address 2001:DB8:1::2/64
ipv6 enable
ipv6 ospf 1 area 11
no shutdown
!
interface Serial1/1
no ip address
ipv6 address 2001:DB8:2::1/64
ipv6 enable
ipv6 ospf 1 area 54
no shutdown
!
ipv6 router ospf 1
router-id 3.3.3.3
area 11 virtual-link 2.2.2.2
!
line vty 0 4
transport input ssh
password cisco
login



===================================

Conf R4


service password-encryption
!
hostname R4
!
enable secret class
!
no ip domain lookup
ip domain name jcs.wan.com
!
ipv6 unicast-routing
!
username josinfo privilege 15 secret class
!
ip ssh time-out 60
ip ssh version 2
!
interface Loopback0
no ip address
ipv6 enable
ipv6 address fec0:4::1/64
ipv6 ospf 1 area 54
!
interface Serial1/0
no ip address
ipv6 address 2001:DB8:2::1/64
ipv6 enable
ipv6 ospf 1 area 54
no shutdown
!
ipv6 router ospf 1
router-id 4.4.4.4
!
line vty 0 4
transport input ssh
password cisco
login

====================================


Comandos de Verificação usados no Troubleshooting do IPv6:
= Show ipv6 route;
= Show ipv6 route ospf;
= show ipv6 ospf neighbor;
= show ipv6 ospf virtual-link;

Caso queira fazer algum comentario, ou tirar duvida fiquem a vontade.

Sds;

JosinfoXtreme

Comentários

Postagens mais visitadas deste blog

Cisco StealthWatch - Na vida Real - Parte01

Cisco DNA Center - Demostração Online do Cisco DNA 2.1.1.S1

Cisco DNA Center: 01 - Na Vida Real - Visão Geral